home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-db / edb-9999 / edb-9999.ebuild < prev    next >
Text File  |  2006-01-09  |  634b  |  26 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-db/edb/edb-9999.ebuild,v 1.5 2005/06/30 22:26:48 vapier Exp $
  4.  
  5. ECVS_MODULE="e17/libs/edb"
  6. inherit enlightenment flag-o-matic
  7.  
  8. DESCRIPTION="Enlightenment Data Base"
  9. HOMEPAGE="http://www.enlightenment.org/Libraries/Edb/"
  10.  
  11. IUSE="gtk ncurses"
  12.  
  13. DEPEND="gtk? ( =x11-libs/gtk+-1* )
  14.     ncurses? ( sys-libs/ncurses )"
  15.  
  16. src_compile() {
  17.     export MY_ECONF="
  18.         --enable-compat185
  19.         --enable-dump185
  20.         $(use_enable gtk)
  21.         $(use_enable ncurses)
  22.     "
  23.     use ppc && filter-lfs-flags
  24.     enlightenment_src_compile
  25. }
  26.